Debian DLA-2895-1 : qt4-x11 - LTS security update

medium Nessus Plugin ID 157047

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2895 advisory.

- Qt SVG in Qt 5.0.0 through 5.15.2 and 6.0.0 through 6.2.1 has an out-of-bounds write in QtPrivate::QCommonArrayOps<QPainterPath::Element>::growAppend (called from QPainterPath::addPath and QPathClipper::intersect). (CVE-2021-45930)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the qt4-x11 packages.

For Debian 9 stretch, these problems have been fixed in version 4

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=986798

https://security-tracker.debian.org/tracker/source-package/qt4-x11

https://www.debian.org/lts/security/2022/dla-2895

https://security-tracker.debian.org/tracker/CVE-2021-3481

https://security-tracker.debian.org/tracker/CVE-2021-45930

https://packages.debian.org/source/stretch/qt4-x11

Plugin Details

Severity: Medium

ID: 157047

File Name: debian_DLA-2895.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/24/2022

Updated: 1/24/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-45930

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libqt4-dbg, p-cpe:/a:debian:debian_linux:libqt4-dbus, p-cpe:/a:debian:debian_linux:libqt4-declarative, p-cpe:/a:debian:debian_linux:libqt4-declarative-folderlistmodel, p-cpe:/a:debian:debian_linux:libqt4-declarative-gestures, p-cpe:/a:debian:debian_linux:libqt4-declarative-particles, p-cpe:/a:debian:debian_linux:libqt4-declarative-shaders, p-cpe:/a:debian:debian_linux:libqt4-designer, p-cpe:/a:debian:debian_linux:libqt4-designer-dbg, p-cpe:/a:debian:debian_linux:libqt4-dev, p-cpe:/a:debian:debian_linux:libqt4-dev-bin, p-cpe:/a:debian:debian_linux:libqt4-help, p-cpe:/a:debian:debian_linux:libqt4-network, p-cpe:/a:debian:debian_linux:libqt4-opengl, p-cpe:/a:debian:debian_linux:libqt4-opengl-dev, p-cpe:/a:debian:debian_linux:libqt4-phonon, p-cpe:/a:debian:debian_linux:libqt4-qt3support, p-cpe:/a:debian:debian_linux:libqt4-qt3support-dbg, p-cpe:/a:debian:debian_linux:libqt4-script, p-cpe:/a:debian:debian_linux:libqt4-script-dbg, p-cpe:/a:debian:debian_linux:libqt4-scripttools, p-cpe:/a:debian:debian_linux:libqt4-sql, p-cpe:/a:debian:debian_linux:libqt4-sql-ibase, p-cpe:/a:debian:debian_linux:libqt4-sql-mysql, p-cpe:/a:debian:debian_linux:libqt4-sql-odbc, p-cpe:/a:debian:debian_linux:libqt4-sql-psql, p-cpe:/a:debian:debian_linux:libqt4-sql-sqlite, p-cpe:/a:debian:debian_linux:libqt4-sql-sqlite2, p-cpe:/a:debian:debian_linux:libqt4-sql-tds, p-cpe:/a:debian:debian_linux:libqt4-svg, p-cpe:/a:debian:debian_linux:libqt4-test, p-cpe:/a:debian:debian_linux:libqt4-xml, p-cpe:/a:debian:debian_linux:libqt4-xmlpatterns, p-cpe:/a:debian:debian_linux:libqt4-xmlpatterns-dbg, p-cpe:/a:debian:debian_linux:libqtcore4, p-cpe:/a:debian:debian_linux:libqtdbus4, p-cpe:/a:debian:debian_linux:libqtgui4, p-cpe:/a:debian:debian_linux:qdbus, p-cpe:/a:debian:debian_linux:qt4-bin-dbg, p-cpe:/a:debian:debian_linux:qt4-default, p-cpe:/a:debian:debian_linux:qt4-demos, p-cpe:/a:debian:debian_linux:qt4-demos-dbg, p-cpe:/a:debian:debian_linux:qt4-designer, p-cpe:/a:debian:debian_linux:qt4-dev-tools, p-cpe:/a:debian:debian_linux:qt4-doc, p-cpe:/a:debian:debian_linux:qt4-doc-html, p-cpe:/a:debian:debian_linux:qt4-linguist-tools, p-cpe:/a:debian:debian_linux:qt4-qmake, p-cpe:/a:debian:debian_linux:qt4-qmlviewer, p-cpe:/a:debian:debian_linux:qt4-qtconfig, p-cpe:/a:debian:debian_linux:qtcore4-l10n, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/24/2022

Vulnerability Publication Date: 11/9/2021

Reference Information

CVE: CVE-2021-3481, CVE-2021-45930