GLSA-202105-22 : Samba: Multiple vulnerabilities

medium Nessus Plugin ID 156990

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202105-22 (Samba: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Samba. Please review the CVE identifiers referenced below for details.
Impact :

Please review the referenced CVE identifiers for details.
Workaround :

There is no known workaround at this time.

Solution

All Samba users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-fs/samba-4.13.8'

See Also

https://security.gentoo.org/glsa/202105-22

Plugin Details

Severity: Medium

ID: 156990

File Name: gentoo_GLSA-202105-22.nasl

Version: 1.2

Type: local

Published: 1/24/2022

Updated: 1/26/2022

Risk Information

CVSS Score Source: CVE-2021-20254

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:samba:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/26/2021

Vulnerability Publication Date: 5/5/2021

Reference Information

CVE: CVE-2020-27840, CVE-2021-20277, CVE-2021-20254

GLSA: 202105-22