Ubuntu 18.04 LTS / 20.04 LTS / 21.10 : USBView vulnerability (USN-5249-1)

high Nessus Plugin ID 156960

Language:

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 21.10 host has a package installed that is affected by a vulnerability as referenced in the USN-5249-1 advisory.

- USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo. (CVE-2022-23220)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected usbview package.

See Also

https://ubuntu.com/security/notices/USN-5249-1

Plugin Details

Severity: High

ID: 156960

File Name: ubuntu_USN-5249-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/22/2022

Updated: 1/22/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-23220

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:21.10, p-cpe:/a:canonical:ubuntu_linux:usbview

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/21/2022

Vulnerability Publication Date: 1/21/2022

Reference Information

CVE: CVE-2022-23220

USN: 5249-1