Debian DSA-5051-1 : aide - security update

high Nessus Plugin ID 156948

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 / 11 host has packages installed that are affected by a vulnerability as referenced in the dsa-5051 advisory.

- AIDE before 0.17.4 allows local users to obtain root privileges via crafted file metadata (such as XFS extended attributes or tmpfs ACLs), because of a heap-based buffer overflow. (CVE-2021-45417)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the aide packages.

For the stable distribution (bullseye), this problem has been fixed in version 0.17.3-4+deb11u1.

See Also

https://security-tracker.debian.org/tracker/source-package/aide

https://www.debian.org/security/2022/dsa-5051

https://security-tracker.debian.org/tracker/CVE-2021-45417

https://packages.debian.org/source/buster/aide

https://packages.debian.org/source/bullseye/aide

Plugin Details

Severity: High

ID: 156948

File Name: debian_DSA-5051.nasl

Version: 1.3

Type: local

Agent: unix

Published: 1/21/2022

Updated: 1/27/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-45417

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:aide, p-cpe:/a:debian:debian_linux:aide-common, p-cpe:/a:debian:debian_linux:aide-dynamic, p-cpe:/a:debian:debian_linux:aide-xen, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/20/2022

Vulnerability Publication Date: 1/20/2022

Reference Information

CVE: CVE-2021-45417