Debian DLA-2890-1 : libspf2 - LTS security update

critical Nessus Plugin ID 156920

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2890 advisory.

- libspf2 before 1.2.11 has a four-byte heap-based buffer overflow that might allow remote attackers to execute arbitrary code (via an unauthenticated e-mail message from anywhere on the Internet) with a crafted SPF DNS record, because of incorrect sprintf usage in SPF_record_expand_data in spf_expand.c. The vulnerable code may be part of the supply chain of a site's e-mail infrastructure (e.g., with additional configuration, Exim can use libspf2; the Postfix web site links to unofficial patches for use of libspf2 with Postfix; older versions of spfquery relied on libspf2) but most often is not. (CVE-2021-33912)

- libspf2 before 1.2.11 has a heap-based buffer overflow that might allow remote attackers to execute arbitrary code (via an unauthenticated e-mail message from anywhere on the Internet) with a crafted SPF DNS record, because of SPF_record_expand_data in spf_expand.c. The amount of overflowed data depends on the relationship between the length of an entire domain name and the length of its leftmost label. The vulnerable code may be part of the supply chain of a site's e-mail infrastructure (e.g., with additional configuration, Exim can use libspf2; the Postfix web site links to unofficial patches for use of libspf2 with Postfix; older versions of spfquery relied on libspf2) but most often is not. (CVE-2021-33913)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the libspf2 packages.

For Debian 9 stretch, these problems have been fixed in version 1.2.10-7+deb9u2.

See Also

https://security-tracker.debian.org/tracker/source-package/libspf2

https://www.debian.org/lts/security/2022/dla-2890

https://security-tracker.debian.org/tracker/CVE-2021-33912

https://security-tracker.debian.org/tracker/CVE-2021-33913

https://packages.debian.org/source/stretch/libspf2

Plugin Details

Severity: Critical

ID: 156920

File Name: debian_DLA-2890.nasl

Version: 1.3

Type: local

Agent: unix

Published: 1/21/2022

Updated: 1/27/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-33913

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libmail-spf-xs-perl, p-cpe:/a:debian:debian_linux:libspf2-2, p-cpe:/a:debian:debian_linux:libspf2-2-dbg, p-cpe:/a:debian:debian_linux:libspf2-dev, p-cpe:/a:debian:debian_linux:spfquery, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/21/2022

Vulnerability Publication Date: 1/19/2022

Reference Information

CVE: CVE-2021-33912, CVE-2021-33913