GLSA-200411-16 : zip: Path name buffer overflow

Critical Nessus Plugin ID 15691


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200411-16 (zip: Path name buffer overflow)

zip does not check the resulting path length when doing recursive folder compression.
Impact :

An attacker could exploit this by enticing another user or web application to create an archive including a specially crafted path name, potentially resulting in the execution of arbitrary code with the permissions of the user running zip.
Workaround :

There is no known workaround at this time.


All zip users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/zip-2.3-r4'

See Also

Plugin Details

Severity: Critical

ID: 15691

File Name: gentoo_GLSA-200411-16.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/11/13

Modified: 2016/04/28

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:zip, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/11/09

Vulnerability Publication Date: 2004/11/03

Reference Information

CVE: CVE-2004-1010

OSVDB: 11414

GLSA: 200411-16