Oracle Primavera P6 Enterprise Project Portfolio Management (Jan 2022 CPU)

high Nessus Plugin ID 156891

Synopsis

The remote host is affected by a vulnerability

Description

The version of Primavera P6 Enterprise Project Portfolio Management installed on the remote host are affected by a vulnerability as referenced in the January 2022 CPU advisory.

- Vulnerability in the Primavera P6 Enterprise Project Portfolio Management product of Oracle Construction and Engineering (component: Web Access (Apache Log4j)). Supported versions that are affected are 19.12.0.0-19.12.18.0, 20.12.0.0-20.12.12.0 and 21.12.0.0. Difficult to exploit vulnerability allows high privileged attacker with network access via HTTP to compromise Primavera P6 Enterprise Project Portfolio Management. Successful attacks of this vulnerability can result in takeover of Primavera P6 Enterprise Project Portfolio Management. Note: This patch also addresses vulnerabilities CVE-2021-44228 and CVE-2021-45046. Customers need not apply the patches/mitigations of Security Alert CVE-2021-44228 and CVE-2021-45046 for this product. (CVE-2021-44832)

- Vulnerability in the Primavera P6 Enterprise Project Portfolio Management product of Oracle Construction and Engineering (component: Web Access (JDBC)). Supported versions that are affected are 17.12.0.0-17.12.20.0, 18.8.0.0-18.8.24.0, 19.12.0.0-19.12.17.0 and 20.12.0.0-20.12.9.0. Difficult to exploit vulnerability allows unauthenticated attacker with network access via Oracle Net to compromise Primavera P6 Enterprise Project Portfolio Management. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Primavera P6 Enterprise Project Portfolio Management, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Primavera P6 Enterprise Project Portfolio Management. (CVE-2021-2351)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Apply the appropriate patch according to the January 2022 Oracle Critical Patch Update advisory.

See Also

https://www.oracle.com/a/tech/docs/cpujan2022cvrf.xml

https://www.oracle.com/security-alerts/cpujan2022.html

Plugin Details

Severity: High

ID: 156891

File Name: oracle_primavera_p6_eppm_cpu_jan_2022.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 1/20/2022

Updated: 7/20/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.7

Vector: AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2021-44832

CVSS v3

Risk Factor: High

Base Score: 8.3

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

CVSS Score Source: CVE-2021-2351

Vulnerability Information

CPE: cpe:/a:oracle:primavera_p6_enterprise_project_portfolio_management

Required KB Items: installed_sw/Oracle Primavera P6 Enterprise Project Portfolio Management (EPPM), www/weblogic

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/18/2022

Vulnerability Publication Date: 1/18/2022

Reference Information

CVE: CVE-2021-2351, CVE-2021-44832

IAVA: 0001-A-0650