Debian DLA-2887-1 : lighttpd - LTS security update

high Nessus Plugin ID 156818

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has packages installed that are affected by a vulnerability as referenced in the dla-2887 advisory.

- An issue was discovered in mod_alias_physical_handler in mod_alias.c in lighttpd before 1.4.50. There is potential ../ path traversal of a single directory above an alias target, with a specific mod_alias configuration where the matched alias lacks a trailing '/' character, but the alias target filesystem path does have a trailing '/' character. (CVE-2018-19052)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the lighttpd packages.

For Debian 9 stretch, this problem has been fixed in version 1.4.45-1+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/lighttpd

https://www.debian.org/lts/security/2022/dla-2887

https://security-tracker.debian.org/tracker/CVE-2018-19052

https://packages.debian.org/source/stretch/lighttpd

Plugin Details

Severity: High

ID: 156818

File Name: debian_DLA-2887.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/19/2022

Updated: 1/19/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2018-19052

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:lighttpd, p-cpe:/a:debian:debian_linux:lighttpd-doc, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-gssapi, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-ldap, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-mysql, p-cpe:/a:debian:debian_linux:lighttpd-mod-cml, p-cpe:/a:debian:debian_linux:lighttpd-mod-geoip, p-cpe:/a:debian:debian_linux:lighttpd-mod-magnet, p-cpe:/a:debian:debian_linux:lighttpd-mod-mysql-vhost, p-cpe:/a:debian:debian_linux:lighttpd-mod-trigger-b4-dl, p-cpe:/a:debian:debian_linux:lighttpd-mod-webdav, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2022

Vulnerability Publication Date: 11/7/2018

Reference Information

CVE: CVE-2018-19052