Ubuntu 16.04 LTS : Ghostscript vulnerabilities (USN-5224-2)

medium Nessus Plugin ID 156743

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5224-2 advisory.

- Ghostscript GhostPDL 9.50 through 9.53.3 has a use-after-free in sampled_data_sample (called from sampled_data_continue and interp). (CVE-2021-45944)

- Ghostscript GhostPDL 9.50 through 9.54.0 has a heap-based buffer overflow in sampled_data_finish (called from sampled_data_continue and interp). (CVE-2021-45949)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5224-2

Plugin Details

Severity: Medium

ID: 156743

File Name: ubuntu_USN-5224-2.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/13/2022

Updated: 1/13/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-45949

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:canonical:ubuntu_linux:16.04:-:lts:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:ghostscript:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libgs9:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:ghostscript-x:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libgs9-common:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libgs-dev:*:*:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 1/13/2022

Vulnerability Publication Date: 1/1/2022

Reference Information

CVE: CVE-2021-45949, CVE-2021-45944

USN: 5224-2