Debian DSA-5040-1 : lighttpd - security update

medium Nessus Plugin ID 156651

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 / 11 host has packages installed that are affected by a vulnerability as referenced in the dsa-5040 advisory.

- In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system. (CVE-2022-22707)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the lighttpd packages.

For the stable distribution (bullseye), this problem has been fixed in version 1.4.59-1+deb11u1.

See Also

https://security-tracker.debian.org/tracker/source-package/lighttpd

https://www.debian.org/security/2022/dsa-5040

https://security-tracker.debian.org/tracker/CVE-2022-22707

https://packages.debian.org/source/buster/lighttpd

https://packages.debian.org/source/bullseye/lighttpd

Plugin Details

Severity: Medium

ID: 156651

File Name: debian_DSA-5040.nasl

Version: 1.3

Type: local

Agent: unix

Published: 1/12/2022

Updated: 1/20/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2022-22707

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:lighttpd, p-cpe:/a:debian:debian_linux:lighttpd-doc, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-gssapi, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-ldap, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-mysql, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-pam, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-sasl, p-cpe:/a:debian:debian_linux:lighttpd-mod-cml, p-cpe:/a:debian:debian_linux:lighttpd-mod-deflate, p-cpe:/a:debian:debian_linux:lighttpd-mod-geoip, p-cpe:/a:debian:debian_linux:lighttpd-mod-magnet, p-cpe:/a:debian:debian_linux:lighttpd-mod-maxminddb, p-cpe:/a:debian:debian_linux:lighttpd-mod-mbedtls, p-cpe:/a:debian:debian_linux:lighttpd-mod-mysql-vhost, p-cpe:/a:debian:debian_linux:lighttpd-mod-nss, p-cpe:/a:debian:debian_linux:lighttpd-mod-openssl, p-cpe:/a:debian:debian_linux:lighttpd-mod-trigger-b4-dl, p-cpe:/a:debian:debian_linux:lighttpd-mod-vhostdb-dbi, p-cpe:/a:debian:debian_linux:lighttpd-mod-vhostdb-pgsql, p-cpe:/a:debian:debian_linux:lighttpd-mod-webdav, p-cpe:/a:debian:debian_linux:lighttpd-mod-wolfssl, p-cpe:/a:debian:debian_linux:lighttpd-modules-dbi, p-cpe:/a:debian:debian_linux:lighttpd-modules-ldap, p-cpe:/a:debian:debian_linux:lighttpd-modules-lua, p-cpe:/a:debian:debian_linux:lighttpd-modules-mysql, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/11/2022

Vulnerability Publication Date: 1/6/2022

Reference Information

CVE: CVE-2022-22707