Debian DSA-5039-1 : wordpress - security update

high Nessus Plugin ID 156616

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 10 / 11 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-5039 advisory.

- WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3.
Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.
(CVE-2022-21661)

- WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Low-privileged authenticated users (like author) in WordPress core are able to execute JavaScript/perform stored XSS attack, which can affect high-privileged users. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue. (CVE-2022-21662)

- WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue. (CVE-2022-21663)

- WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue. (CVE-2022-21664)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the wordpress packages.

For the stable distribution (bullseye), these problems have been fixed in version 5.7.5+dfsg1-0+deb11u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1003243

https://security-tracker.debian.org/tracker/source-package/wordpress

https://www.debian.org/security/2022/dsa-5039

https://security-tracker.debian.org/tracker/CVE-2022-21661

https://security-tracker.debian.org/tracker/CVE-2022-21662

https://security-tracker.debian.org/tracker/CVE-2022-21663

https://security-tracker.debian.org/tracker/CVE-2022-21664

https://packages.debian.org/source/buster/wordpress

https://packages.debian.org/source/bullseye/wordpress

Plugin Details

Severity: High

ID: 156616

File Name: debian_DSA-5039.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/11/2022

Updated: 1/20/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2022-21664

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:wordpress, p-cpe:/a:debian:debian_linux:wordpress-l10n, p-cpe:/a:debian:debian_linux:wordpress-theme-twentynineteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentyseventeen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentysixteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwenty, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwentyone, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/11/2022

Vulnerability Publication Date: 1/11/2022

Reference Information

CVE: CVE-2022-21661, CVE-2022-21662, CVE-2022-21663, CVE-2022-21664

IAVA: 2022-A-0003