GLSA-200411-14 : Kaffeine, gxine: Remotely exploitable buffer overflow

Critical Nessus Plugin ID 15648


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200411-14 (Kaffeine, gxine: Remotely exploitable buffer overflow)

KF of Secure Network Operations has discovered an overflow that occurs during the Content-Type header processing of Kaffeine. The vulnerable code in Kaffeine is reused from gxine, making gxine vulnerable as well.
Impact :

An attacker could create a specially crafted Content-type header from a malicious HTTP server, and crash a user's instance of Kaffeine or gxine, potentially allowing the execution of arbitrary code.
Workaround :

There is no known workaround at this time.


All Kaffeine users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-video/kaffeine-0.4.3b-r1' All gxine users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-video/gxine-0.3.3-r1'

See Also

Plugin Details

Severity: Critical

ID: 15648

File Name: gentoo_GLSA-200411-14.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/11/08

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gxine, p-cpe:/a:gentoo:linux:kaffeine, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/11/07

Vulnerability Publication Date: 2004/10/25

Reference Information

CVE: CVE-2004-1034

OSVDB: 11197

GLSA: 200411-14