JQuery UI < 1.13.0 Multiple XSS

medium Nessus Plugin ID 156443

Synopsis

The remote web server is affected by multiple cross-site scripting vulnerabilities.

Description

The version of JQuery UI library hosted on the remote web server is prior to 1.13.0. It is, therefore, affected by multiple cross-site scripting vulnerabilities:

- Accepting the value of the 'altField' option of the Datepicker widget from untrusted sources may execute untrusted code. (CVE-2021-41182)

- Accepting the value of various '*Text' options of the Datepicker widget from untrusted sources may execute untrusted code. (CVE-2021-41183)

- Accepting the value of the 'of' option of the '.position()' util from untrusted sources may execute untrusted code. (CVE-2021-41184)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to JQuery UI version 1.13.0 or later.

See Also

https://blog.jqueryui.com/2021/10/jquery-ui-1-13-0-released/

Plugin Details

Severity: Medium

ID: 156443

File Name: jquery-ui_1_13_0.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 12/31/2021

Updated: 1/3/2022

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-41184

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery_ui

Exploit Ease: No known exploits are available

Patch Publication Date: 10/7/2021

Vulnerability Publication Date: 10/7/2021

Reference Information

CVE: CVE-2021-41182, CVE-2021-41183, CVE-2021-41184

IAVB: 2021-B-0071