GLSA-200411-10 : Gallery: XSS vulnerability

Medium Nessus Plugin ID 15644


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200411-10 (Gallery: XSS vulnerability)

Jim Paris has discovered a cross-site scripting vulnerability in Gallery.
Impact :

By sending a carefully crafted URL, an attacker can inject and execute script code in the victim's browser window, and potentially compromise the users gallery.
Workaround :

There is no known workaround at this time.


All Gallery users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/gallery-1.4.4_p4'

See Also

Plugin Details

Severity: Medium

ID: 15644

File Name: gentoo_GLSA-200411-10.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2004/11/07

Modified: 2017/08/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:ND/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gallery, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2004/11/06

Vulnerability Publication Date: 2004/11/03

Reference Information

CVE: CVE-2004-1106

OSVDB: 11340

GLSA: 200411-10