Debian DLA-2868-1 : advancecomp - LTS security update

high Nessus Plugin ID 156394

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has a package installed that is affected by multiple vulnerabilities as referenced in the dla-2868 advisory.

- An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files. (CVE-2018-1056)

- An issue was discovered in AdvanceCOMP through 2.1. A NULL pointer dereference exists in the function be_uint32_read() located in endianrw.h. It can be triggered by sending a crafted file to a binary. It allows an attacker to cause a Denial of Service (Segmentation fault) or possibly have unspecified other impact when a victim opens a specially crafted file. (CVE-2019-8379)

- An issue was discovered in AdvanceCOMP through 2.1. An invalid memory address occurs in the function adv_png_unfilter_8 in lib/png.c. It can be triggered by sending a crafted file to a binary. It allows an attacker to cause a Denial of Service (Segmentation fault) or possibly have unspecified other impact when a victim opens a specially crafted file. (CVE-2019-8383)

- In AdvanceCOMP 2.1, png_compress in pngex.cc in advpng has an integer overflow upon encountering an invalid PNG size, which results in an attempted memcpy to write into a buffer that is too small. (There is also a heap-based buffer over-read.) (CVE-2019-9210)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the advancecomp packages.

For Debian 9 stretch, these problems have been fixed in version 1.20-1+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=889270

https://security-tracker.debian.org/tracker/source-package/advancecomp

https://www.debian.org/lts/security/2021/dla-2868

https://security-tracker.debian.org/tracker/CVE-2018-1056

https://security-tracker.debian.org/tracker/CVE-2019-8379

https://security-tracker.debian.org/tracker/CVE-2019-8383

https://security-tracker.debian.org/tracker/CVE-2019-9210

https://packages.debian.org/source/stretch/advancecomp

Plugin Details

Severity: High

ID: 156394

File Name: debian_DLA-2868.nasl

Version: 1.2

Type: local

Agent: unix

Published: 12/30/2021

Updated: 12/30/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

CVSS Score Source: CVE-2019-9210

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:advancecomp, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/29/2021

Vulnerability Publication Date: 3/7/2018

Reference Information

CVE: CVE-2018-1056, CVE-2019-8379, CVE-2019-8383, CVE-2019-9210