Mandrake Linux Security Advisory : xorg-x11 (MDKSA-2004:124)

High Nessus Plugin ID 15635


The remote Mandrake Linux host is missing one or more security updates.


Chris Evans found several stack and integer overflows in the libXpm code of X.Org/XFree86 :

Stack overflows (CVE-2004-0687) :

Careless use of strcat() in both the XPMv1 and XPMv2/3 xpmParseColors code leads to a stack based overflow (parse.c).

Stack overflow reading pixel values in ParseAndPutPixels (create.c) as well as ParsePixels (parse.c).

Integer Overflows (CVE-2004-0688) :

Integer overflow allocating colorTable in xpmParseColors (parse.c) - probably a crashable but not exploitable offence.

Additionally, the xorg-x11 packages have been patched with a backport from cvs to resolve a failure running the lsb-test-vsw4 test suite, which will soon be required for LSB2.0 compliance.

The updated packages have patches from Chris Evans and Matthieu Herrb to address these vulnerabilities.


Update the affected packages.

Plugin Details

Severity: High

ID: 15635

File Name: mandrake_MDKSA-2004-124.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2004/11/05

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:X11R6-contrib, p-cpe:/a:mandriva:linux:lib64xorg-x11, p-cpe:/a:mandriva:linux:lib64xorg-x11-devel, p-cpe:/a:mandriva:linux:lib64xorg-x11-static-devel, p-cpe:/a:mandriva:linux:libxorg-x11, p-cpe:/a:mandriva:linux:libxorg-x11-devel, p-cpe:/a:mandriva:linux:libxorg-x11-static-devel, p-cpe:/a:mandriva:linux:xorg-x11, p-cpe:/a:mandriva:linux:xorg-x11-100dpi-fonts, p-cpe:/a:mandriva:linux:xorg-x11-75dpi-fonts, p-cpe:/a:mandriva:linux:xorg-x11-Xnest, p-cpe:/a:mandriva:linux:xorg-x11-Xvfb, p-cpe:/a:mandriva:linux:xorg-x11-cyrillic-fonts, p-cpe:/a:mandriva:linux:xorg-x11-doc, p-cpe:/a:mandriva:linux:xorg-x11-glide-module, p-cpe:/a:mandriva:linux:xorg-x11-server, p-cpe:/a:mandriva:linux:xorg-x11-xfs, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/11/04

Reference Information

CVE: CVE-2004-0687, CVE-2004-0688

MDKSA: 2004:124