Debian DLA-2853-1 : ruby2.3 - LTS security update

high Nessus Plugin ID 156329

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2853 advisory.

- Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1. (CVE-2021-41817)

- CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby. (CVE-2021-41819)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ruby2.3 packages.

For Debian 9 stretch, these problems have been fixed in version 2.3.3-1+deb9u11.

See Also

https://security-tracker.debian.org/tracker/source-package/ruby2.3

https://www.debian.org/lts/security/2021/dla-2853

https://security-tracker.debian.org/tracker/CVE-2021-41817

https://security-tracker.debian.org/tracker/CVE-2021-41819

https://packages.debian.org/source/stretch/ruby2.3

Plugin Details

Severity: High

ID: 156329

File Name: debian_DLA-2853.nasl

Version: 1.4

Type: local

Agent: unix

Published: 12/28/2021

Updated: 1/20/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-41819

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libruby2.3, p-cpe:/a:debian:debian_linux:ruby2.3, p-cpe:/a:debian:debian_linux:ruby2.3-dev, p-cpe:/a:debian:debian_linux:ruby2.3-doc, p-cpe:/a:debian:debian_linux:ruby2.3-tcltk, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/28/2021

Vulnerability Publication Date: 12/28/2021

Reference Information

CVE: CVE-2021-41817, CVE-2021-41819