Debian DLA-2849-1 : wireshark - LTS security update

high Nessus Plugin ID 156315

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2849 advisory.

- Excessive memory consumption in MS-WSP dissector in Wireshark 3.4.0 to 3.4.4 and 3.2.0 to 3.2.12 allows denial of service via packet injection or crafted capture file (CVE-2021-22207)

- Crash in DNP dissector in Wireshark 3.4.0 to 3.4.6 and 3.2.0 to 3.2.14 allows denial of service via packet injection or crafted capture file (CVE-2021-22235)

- NULL pointer exception in the Modbus dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39921)

- Buffer overflow in the C12.22 dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39922)

- Large loop in the PNRP dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39923)

- Large loop in the Bluetooth DHT dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39924)

- Buffer overflow in the Bluetooth SDP dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39925)

- NULL pointer exception in the IEEE 802.11 dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39928)

- Uncontrolled Recursion in the Bluetooth DHT dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file (CVE-2021-39929)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the wireshark packages.

For Debian 9 stretch, these problems have been fixed in version 2.6.20-0+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=987853

https://security-tracker.debian.org/tracker/source-package/wireshark

https://www.debian.org/lts/security/2021/dla-2849

https://security-tracker.debian.org/tracker/CVE-2021-22207

https://security-tracker.debian.org/tracker/CVE-2021-22235

https://security-tracker.debian.org/tracker/CVE-2021-39921

https://security-tracker.debian.org/tracker/CVE-2021-39922

https://security-tracker.debian.org/tracker/CVE-2021-39923

https://security-tracker.debian.org/tracker/CVE-2021-39924

https://security-tracker.debian.org/tracker/CVE-2021-39925

https://security-tracker.debian.org/tracker/CVE-2021-39928

https://security-tracker.debian.org/tracker/CVE-2021-39929

https://packages.debian.org/source/stretch/wireshark

Plugin Details

Severity: High

ID: 156315

File Name: debian_DLA-2849.nasl

Version: 1.4

Type: local

Agent: unix

Published: 12/27/2021

Updated: 9/27/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39929

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libwireshark-data, p-cpe:/a:debian:debian_linux:libwireshark-dev, p-cpe:/a:debian:debian_linux:libwireshark11, p-cpe:/a:debian:debian_linux:libwireshark8, p-cpe:/a:debian:debian_linux:libwiretap-dev, p-cpe:/a:debian:debian_linux:libwiretap6, p-cpe:/a:debian:debian_linux:libwiretap8, p-cpe:/a:debian:debian_linux:libwscodecs1, p-cpe:/a:debian:debian_linux:libwscodecs2, p-cpe:/a:debian:debian_linux:libwsutil-dev, p-cpe:/a:debian:debian_linux:libwsutil7, p-cpe:/a:debian:debian_linux:libwsutil9, p-cpe:/a:debian:debian_linux:tshark, p-cpe:/a:debian:debian_linux:wireshark, p-cpe:/a:debian:debian_linux:wireshark-common, p-cpe:/a:debian:debian_linux:wireshark-dev, p-cpe:/a:debian:debian_linux:wireshark-doc, p-cpe:/a:debian:debian_linux:wireshark-gtk, p-cpe:/a:debian:debian_linux:wireshark-qt, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/26/2021

Vulnerability Publication Date: 4/21/2021

Reference Information

CVE: CVE-2021-22207, CVE-2021-22235, CVE-2021-39921, CVE-2021-39922, CVE-2021-39923, CVE-2021-39924, CVE-2021-39925, CVE-2021-39928, CVE-2021-39929

IAVB: 2021-B-0065-S, 2021-B-0028-S