Ability FTP Server Multiple Command Remote Buffer Overflows

Critical Nessus Plugin ID 15628


The remote FTP server is vulnerable to multiple remote buffer overflow attacks.


The remote host is running Ability FTP Server. It is reported that the remote version of this software is prone to a remote buffer overflow attack via the 'STOR' and 'APPE' commands. An attacker, exploiting this flaw, would only need to be able to craft and send a query to the FTP server on its service port (usually 21).


Upgrade to Ability FTP Server version 2.35 or newer.

See Also



Plugin Details

Severity: Critical

ID: 15628

File Name: ability_ftp_overflow.nasl

Version: $Revision: 1.15 $

Type: remote

Family: FTP

Published: 2004/11/04

Modified: 2016/11/15

Dependencies: 10092

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/10/22

Exploitable With

Metasploit (Ability Server 2.34 STOR Command Stack Buffer Overflow)

Reference Information

CVE: CVE-2004-1626, CVE-2004-1627

BID: 11508

OSVDB: 11030, 12347

Secunia: 12941