Debian DSA-5023-1 : modsecurity-apache - security update

high Nessus Plugin ID 156186

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 / 11 host has a package installed that is affected by a vulnerability as referenced in the dsa-5023 advisory.

- ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests.
Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4. (CVE-2021-42717)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the modsecurity-apache packages.

For the stable distribution (bullseye), this problem has been fixed in version 2.9.3-3+deb11u1.

See Also

http://www.nessus.org/u?b86f5745

https://www.debian.org/security/2021/dsa-5023

https://security-tracker.debian.org/tracker/CVE-2021-42717

https://packages.debian.org/source/buster/modsecurity-apache

https://packages.debian.org/source/bullseye/modsecurity-apache

Plugin Details

Severity: High

ID: 156186

File Name: debian_DSA-5023.nasl

Version: 1.2

Type: local

Agent: unix

Published: 12/19/2021

Updated: 12/19/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-42717

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libapache2-mod-security2, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/18/2021

Vulnerability Publication Date: 12/7/2021

Reference Information

CVE: CVE-2021-42717