GLSA-200410-28 : rssh: Format string vulnerability

Critical Nessus Plugin ID 15580


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200410-28 (rssh: Format string vulnerability)

Florian Schilhabel from the Gentoo Linux Security Audit Team found a format string vulnerability in rssh syslogging of failed commands.
Impact :

Using a malicious command, it may be possible for a remote authenticated user to execute arbitrary code on the target machine with user rights, effectively bypassing any restriction of rssh.
Workaround :

There is no known workaround at this time.


All rssh users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/rssh-2.2.2'

See Also

Plugin Details

Severity: Critical

ID: 15580

File Name: gentoo_GLSA-200410-28.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2004/10/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:rssh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/10/27

Vulnerability Publication Date: 2004/10/23

Reference Information

CVE: CVE-2004-1628

OSVDB: 11110

GLSA: 200410-28