CentOS 7 : openssh (CESA-2021:4782)

high Nessus Plugin ID 155757

Synopsis

The remote CentOS Linux host is missing a security update.

Description

The remote CentOS Linux 7 host has packages installed that are affected by a vulnerability as referenced in the CESA-2021:4782 advisory.

- openssh: privilege escalation when AuthorizedKeysCommand or AuthorizedPrincipalsCommand are configured (CVE-2021-41617)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?bae03048

https://cwe.mitre.org/data/definitions/273.html

Plugin Details

Severity: High

ID: 155757

File Name: centos_RHSA-2021-4782.nasl

Version: 1.2

Type: local

Agent: unix

Published: 12/1/2021

Updated: 12/1/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

CVSS Score Source: CVE-2021-41617

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:openssh, p-cpe:/a:centos:centos:openssh-askpass, p-cpe:/a:centos:centos:openssh-cavs, p-cpe:/a:centos:centos:openssh-clients, p-cpe:/a:centos:centos:openssh-keycat, p-cpe:/a:centos:centos:openssh-ldap, p-cpe:/a:centos:centos:openssh-server, p-cpe:/a:centos:centos:openssh-server-sysvinit, p-cpe:/a:centos:centos:pam_ssh_agent_auth, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/1/2021

Vulnerability Publication Date: 9/26/2021

Reference Information

CVE: CVE-2021-41617

IAVA: 2021-A-0474

RHSA: 2021:4782

CWE: 273