PHP 7.3.x < 7.3.33

medium Nessus Plugin ID 155590

Synopsis

The version PHP running on the remote web server is affected by a vulnerability.

Description

The version of PHP installed on the remote host is prior to 7.3.33. It is, therefore, affected by a vulnerability as referenced in the Version 7.3.33 advisory.

- In PHP versions 7.3.x below 7.3.33, 7.4.x below 7.4.26 and 8.0.x below 8.0.13, certain XML parsing functions, like simplexml_load_file(), URL-decode the filename passed to them. If that filename contains URL-encoded NUL character, this may cause the function to interpret this as the end of the filename, thus interpreting the filename differently from what the user intended, which may lead it to reading a different file than intended. (CVE-2021-21707)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.3.33 or later.

See Also

http://bugs.php.net/79971

http://php.net/ChangeLog-7.php#7.3.33

Plugin Details

Severity: Medium

ID: 155590

File Name: php_7_3_33.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 11/18/2021

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2021-21707

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 11/18/2021

Vulnerability Publication Date: 11/18/2021

Reference Information

CVE: CVE-2021-21707

IAVA: 2021-A-0566