Drupal 8.9.x < 8.9.20 / 9.1.x < 9.1.14 / 9.2.x < 9.2.9 Multiple Vulnerabilities (drupal-2021-11-17)

medium Nessus Plugin ID 155559

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.9.x prior to 8.9.20, 9.1.x prior to 9.1.14, or 9.2.x prior to 9.2.9. It is, therefore, affected by multiple vulnerabilities.

- CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0. (CVE-2021-41164)

- CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0. (CVE-2021-41165)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 8.9.20 / 9.1.14 / 9.2.9 or later.

See Also

https://www.drupal.org/sa-core-2021-011

https://ckeditor.com/cke4/release/CKEditor-4.17.0

https://ckeditor.com/cke4/release/CKEditor-4.17.1

https://github.com/ckeditor/ckeditor4

http://www.nessus.org/u?b93a11ed

http://www.nessus.org/u?1789d069

https://www.drupal.org/project/drupal/releases/8.9.20

https://www.drupal.org/project/drupal/releases/9.1.14

https://www.drupal.org/project/drupal/releases/9.2.9

https://www.drupal.org/psa-2021-06-29

https://www.drupal.org/steward

Plugin Details

Severity: Medium

ID: 155559

File Name: drupal_9_2_9.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 11/18/2021

Updated: 4/11/2022

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-41165

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 11/17/2021

Vulnerability Publication Date: 11/17/2021

Reference Information

CVE: CVE-2021-41164, CVE-2021-41165

IAVA: 2021-A-0559