Apache mod_include get_tag() Function Local Overflow

medium Nessus Plugin ID 15554


The remote web server is affected by a local buffer overflow vulnerability.


The remote web server appears to be running a version of Apache that is older than version 1.3.33.

This version is vulnerable to a local buffer overflow in the get_tag() function of the module 'mod_include' when a specially crafted document with malformed server-side includes is requested though an HTTP session.

Successful exploitation can lead to execution of arbitrary code with escalated privileges, but requires that server-side includes (SSI) is enabled.


Upgrade to Apache 1.3.33 or later.

Plugin Details

Severity: Medium

ID: 15554

File Name: apache_mod_include_priv_escalation.nasl

Version: 1.27

Type: remote

Family: Web Servers

Published: 10/25/2004

Updated: 6/12/2020

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: www/apache, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 10/21/2004

Reference Information

CVE: CVE-2004-0940

BID: 11471

CWE: 119

RHSA: 2005:816

Secunia: 12898, 19073