CentOS 7 : firefox (CESA-2021:4116)

critical Nessus Plugin ID 155539

Synopsis

The remote CentOS Linux host is missing one or more security updates.

Description

The remote CentOS Linux 7 host has a package installed that is affected by multiple vulnerabilities as referenced in the CESA-2021:4116 advisory.

- Mozilla: iframe sandbox rules did not apply to XSLT stylesheets (CVE-2021-38503)

- Mozilla: Use-after-free in file picker dialog (CVE-2021-38504)

- Mozilla: Firefox could be coaxed into going into fullscreen mode without notification or warning (CVE-2021-38506)

- Mozilla: Opportunistic Encryption in HTTP2 could be used to bypass the Same-Origin-Policy on services hosted on other ports (CVE-2021-38507)

- Mozilla: Permission Prompt could be overlaid, resulting in user confusion and potential spoofing (CVE-2021-38508)

- Mozilla: Javascript alert box could have been spoofed onto an arbitrary domain (CVE-2021-38509)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected firefox package.

See Also

http://www.nessus.org/u?e1e2ffcf

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/732.html

https://cwe.mitre.org/data/definitions/829.html

https://cwe.mitre.org/data/definitions/1021.html

Plugin Details

Severity: Critical

ID: 155539

File Name: centos_RHSA-2021-4116.nasl

Version: 1.7

Type: local

Agent: unix

Published: 11/17/2021

Updated: 3/17/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

CVSS Score Source: CVE-2021-38503

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:firefox, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 11/17/2021

Vulnerability Publication Date: 11/2/2021

Reference Information

CVE: CVE-2021-38503, CVE-2021-38504, CVE-2021-38506, CVE-2021-38507, CVE-2021-38508, CVE-2021-38509

IAVA: 2021-A-0527-S

RHSA: 2021:4116

CWE: 416, 732, 829, 1021