Mandrake Linux Security Advisory : gpdf (MDKSA-2004:114)

Critical Nessus Plugin ID 15549


The remote Mandrake Linux host is missing a security update.


Chris Evans discovered numerous vulnerabilities in the xpdf package, which also effect software using embedded xpdf code, such as gpdf :

Multiple integer overflow issues affecting xpdf-2.0 and xpdf-3.0. Also programs like gpdf which have embedded versions of xpdf. These can result in writing an arbitrary byte to an attacker controlled location which probably could lead to arbitrary code execution.

The updated packages are patched to protect against these vulnerabilities.


Update the affected gpdf package.

Plugin Details

Severity: Critical

ID: 15549

File Name: mandrake_MDKSA-2004-114.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/10/22

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gpdf, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/10/21

Reference Information

CVE: CVE-2004-0888

MDKSA: 2004:114