Palo Alto Networks PAN-OS 8.1.x < 8.1.17 Memory Corruption

critical Nessus Plugin ID 155307

Synopsis

The remote PAN-OS host is affected by a memory corruption vulnerability.

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 8.1.x prior to 8.1.17. It is, therefore, affected by a memory corruption vulnerability. This vulnerability exists in Palo Alto Networks GlobalProtect portal and gateway interfaces that enables an unauthenticated network-based attacker to disrupt system processes and potentially execute arbitrary code with root privileges. The attacker must have network access to the GlobalProtect interface to exploit this issue.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PAN-OS 8.1.17 or later

See Also

https://security.paloaltonetworks.com/CVE-2021-3064

https://cwe.mitre.org/data/definitions/121.html

Plugin Details

Severity: Critical

ID: 155307

File Name: palo_alto_CVE-2021-3064.nasl

Version: 1.4

Type: combined

Published: 11/12/2021

Updated: 5/26/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-3064

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 11/10/2021

Vulnerability Publication Date: 11/10/2021

Reference Information

CVE: CVE-2021-3064

IAVA: 2021-A-0552-S

CWE: 121