Mandrake Linux Security Advisory : cvs (MDKSA-2004:108)

Medium Nessus Plugin ID 15522


The remote Mandrake Linux host is missing a security update.


iDEFENSE discovered a flaw in CVS versions prior to 1.1.17 in an undocumented switch implemented in CVS' history command. The -X switch specifies the name of the history file which allows an attacker to determine whether arbitrary system files and directories exist and whether or not the CVS process has access to them.

This flaw has been fixed in CVS version 1.1.17.


Update the affected cvs package.

See Also

Plugin Details

Severity: Medium

ID: 15522

File Name: mandrake_MDKSA-2004-108.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2004/10/20

Modified: 2013/06/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cvs, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/10/19

Reference Information

CVE: CVE-2004-0778

MDKSA: 2004:108