Adobe Creative Cloud Desktop Application < 5.6 Multiple Vulnerabilities (APSB21-111) (macOS)

high Nessus Plugin ID 155137

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of Adobe Creative Cloud Desktop Application installed on the remote macOS host is prior to 5.6. It is, therefore, affected by multiple vulnerabilities.

- Creation of a temporary file in a directory with incorrect permissions allows an authenticated, local attacker to execute arbitrary code. (CVE-2021-43017)

- Improper access control allows an unauthenticated, local attacker to escalate privileges. (CVE-2021-43019)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Creative Cloud Desktop Application version 5.6 or later.

See Also

http://www.nessus.org/u?6eea7a58

Plugin Details

Severity: High

ID: 155137

File Name: macosx_adobe_creative_cloud_apsb21-111.nasl

Version: 1.5

Type: local

Agent: macosx

Published: 11/11/2021

Updated: 11/30/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-43019

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:creative_cloud

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Creative Cloud

Exploit Ease: No known exploits are available

Patch Publication Date: 10/13/2021

Vulnerability Publication Date: 11/10/2021

Reference Information

CVE: CVE-2021-43017, CVE-2021-43019

IAVA: 2021-A-0547