GLSA-200410-15 : Squid: Remote DoS vulnerability

Medium Nessus Plugin ID 15512


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200410-15 (Squid: Remote DoS vulnerability)

A parsing error exists in the SNMP module of Squid where a specially crafted UDP packet can potentially cause the server to restart, closing all current connections. This vulnerability only exists in versions of Squid compiled with the 'snmp' USE flag.
Impact :

An attacker can repeatedly send these malicious UDP packets to the Squid server, leading to a denial of service.
Workaround :

Disable SNMP support or filter the port that has SNMP processing (default is 3401) to allow only SNMP data from trusted hosts.
To disable SNMP support put the entry snmp_port 0 in the squid.conf configuration file.
To allow only the local interface to process SNMP, add the entry 'snmp_incoming_address' in the squid.conf configuration file.


All Squid users should upgrade to the latest version:
# emerge sync # emerge -pv '>=net-proxy/squid-2.5.7' # emerge '>=net-proxy/squid-2.5.7'

See Also

Plugin Details

Severity: Medium

ID: 15512

File Name: gentoo_GLSA-200410-15.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2004/10/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:squid, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/10/18

Vulnerability Publication Date: 2004/10/05

Reference Information

CVE: CVE-2004-0918

OSVDB: 10675

GLSA: 200410-15

CWE: 399