GitLab 7.12.x < 13.8.8 / 13.9.x < 13.9.6 / 13.10.x < 13.10.3 RCE

critical Nessus Plugin ID 154879

Synopsis

A source control application running on the remote web server is affected by a remote code execution vulnerability.

Description

According to its self-reported version, the instance of GitLab running on the remote web server is prior to 13.8.8, 13.9.x prior to 13.9.6, or 13.10.x prior to 13.10.3. It is, therefore, affected by a remote code execution due to not properly validating image files being passed to a file parser. An authenticated, remote attacker can exploit this, by uploading a malicious image file, to execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 13.8.8 / 13.9.6 / 13.10.3 or later.

See Also

http://www.nessus.org/u?e0f673b6

Plugin Details

Severity: Critical

ID: 154879

File Name: gitlab_13_10_3.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 11/3/2021

Updated: 1/13/2022

Risk Information

CVSS Score Source: CVE-2021-22205

VPR

Risk Factor: Critical

Score: 10

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/14/2021

Vulnerability Publication Date: 4/14/2021

CISA Known Exploited Dates: 11/17/2021

Exploitable With

Metasploit (GitLab Unauthenticated Remote ExifTool Command Injection)

Reference Information

CVE: CVE-2021-22205

IAVA: 2021-A-0523-S