PHP 7.3.x < 7.3.32

high Nessus Plugin ID 154663

Synopsis

The version PHP running on the remote web server is affected by a vulnerability.

Description

The version of PHP installed on the remote host is prior to 7.3.32. It is, therefore, affected by a vulnerability as referenced in the Version 7.3.32 advisory.

- In PHP versions 7.3.x up to and including 7.3.31, 7.4.x below 7.4.25 and 8.0.x below 8.0.12, when running PHP FPM SAPI with main FPM daemon process running as root and child worker processes running as lower- privileged users, it is possible for the child processes to access memory shared with the main process and write to it, modifying it in a way that would cause the root process to conduct invalid memory reads and writes, which can be used to escalate privileges from local unprivileged user to the root user.
(CVE-2021-21703)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.3.32 or later.

See Also

http://bugs.php.net/81026

http://php.net/ChangeLog-7.php#7.3.32

Plugin Details

Severity: High

ID: 154663

File Name: php_7_3_32.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 10/28/2021

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2021-21703

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 10/28/2021

Vulnerability Publication Date: 10/25/2021

Reference Information

CVE: CVE-2021-21703

IAVA: 2021-A-0503