MS04-031: Vulnerability in NetDDE Could Allow Code Execution (841533)

Critical Nessus Plugin ID 15456

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.3

Synopsis

Arbitrary code can be executed on the remote host through the NetDDE service.

Description

The remote version of Windows is affected by a vulnerability in Network Dynamic Data Exchange (NetDDE).

To exploit this flaw, NetDDE would have to be running and an attacker with a specific knowledge of the vulnerability would need to send a malformed NetDDE message to the remote host to overrun a given buffer.

A public exploit is available to exploit this vulnerability.

Solution

Microsoft has released a set of patches for Windows NT, 2000, XP and 2003.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2004/ms04-031

Plugin Details

Severity: Critical

ID: 15456

File Name: smb_nt_ms04-031.nasl

Version: 1.35

Type: local

Agent: windows

Published: 2004/10/12

Updated: 2018/11/15

Dependencies: 13855, 57033

Risk Information

Risk Factor: Critical

VPR Score: 7.3

CVSS v2.0

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/10/12

Vulnerability Publication Date: 2004/10/12

Exploitable With

CANVAS (CANVAS)

Metasploit (MS04-031 Microsoft NetDDE Service Overflow)

Reference Information

CVE: CVE-2004-0206

BID: 11372

MSFT: MS04-031

MSKB: 841533