GLSA-200410-09 : LessTif: Integer and stack overflows in libXpm

High Nessus Plugin ID 15447


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200410-09 (LessTif: Integer and stack overflows in libXpm)

Chris Evans has discovered various integer and stack overflows in libXpm, which is shipped as a part of the X Window System. LessTif, an application that includes this library, is susceptible to the same issues.
Impact :

A carefully-crafted XPM file could crash applications that are linked against libXpm, such as LessTif, potentially allowing the execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All LessTif users should upgrade to the latest version:
# emerge sync # emerge -pv '>=x11-libs/lesstif-0.93.97' # emerge '>=x11-libs/lesstif-0.93.97'

See Also

Plugin Details

Severity: High

ID: 15447

File Name: gentoo_GLSA-200410-09.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2004/10/11

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lesstif, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/10/09

Vulnerability Publication Date: 2004/09/15

Reference Information

CVE: CVE-2004-0687, CVE-2004-0688

OSVDB: 10026, 10027, 10028, 10029, 10030, 10031, 10032, 10033, 10034

GLSA: 200410-09