GLSA-200410-08 : ncompress: Buffer overflow

High Nessus Plugin ID 15446


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200410-08 (ncompress: Buffer overflow)

compress and uncompress do not properly check bounds on command line options, including the filename. Large parameters would trigger a buffer overflow.
Impact :

By supplying a carefully crafted filename or other option, an attacker could execute arbitrary code on the system. A local attacker could only execute code with his own rights, but since compress and uncompress are called by various daemon programs, this might also allow a remote attacker to execute code with the rights of the daemon making use of ncompress.
Workaround :

There is no known workaround at this time.


All ncompress users should upgrade to the latest version:
# emerge sync # emerge -pv '>=app-arch/ncompress-4.2.4-r1' # emerge '>=app-arch/ncompress-4.2.4-r1'

See Also

Plugin Details

Severity: High

ID: 15446

File Name: gentoo_GLSA-200410-08.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/10/09

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ncompress, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/10/09

Vulnerability Publication Date: 2001/11/20

Reference Information

CVE: CVE-2001-1413

OSVDB: 10636

CERT: 176363

GLSA: 200410-08