Debian DSA-4992-1 : php7.4 - security update

high Nessus Plugin ID 154432


New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Debian host is missing a security-related update.


The remote Debian 11 host has packages installed that are affected by a vulnerability as referenced in the dsa-4992 advisory.

- In PHP versions 7.3.x up to and including 7.3.31, 7.4.x below 7.4.25 and 8.0.x below 8.0.12, when running PHP FPM SAPI with main FPM daemon process running as root and child worker processes running as lower- privileged users, it is possible for the child processes to access memory shared with the main process and write to it, modifying it in a way that would cause the root process to conduct invalid memory reads and writes, which can be used to escalate privileges from local unprivileged user to the root user.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the php7.4 packages.

For the stable distribution (bullseye), this problem has been fixed in version 7.4.25-1+deb11u1.

See Also

Plugin Details

Severity: High

ID: 154432

File Name: debian_DSA-4992.nasl

Version: 1.3

Type: local

Agent: unix

Published: 10/26/2021

Updated: 10/29/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-21703


Risk Factor: High

Score: 7.4


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libapache2-mod-php7.4, p-cpe:/a:debian:debian_linux:libphp7.4-embed, p-cpe:/a:debian:debian_linux:php7.4, p-cpe:/a:debian:debian_linux:php7.4-bcmath, p-cpe:/a:debian:debian_linux:php7.4-bz2, p-cpe:/a:debian:debian_linux:php7.4-cgi, p-cpe:/a:debian:debian_linux:php7.4-cli, p-cpe:/a:debian:debian_linux:php7.4-common, p-cpe:/a:debian:debian_linux:php7.4-curl, p-cpe:/a:debian:debian_linux:php7.4-dba, p-cpe:/a:debian:debian_linux:php7.4-dev, p-cpe:/a:debian:debian_linux:php7.4-enchant, p-cpe:/a:debian:debian_linux:php7.4-fpm, p-cpe:/a:debian:debian_linux:php7.4-gd, p-cpe:/a:debian:debian_linux:php7.4-gmp, p-cpe:/a:debian:debian_linux:php7.4-imap, p-cpe:/a:debian:debian_linux:php7.4-interbase, p-cpe:/a:debian:debian_linux:php7.4-intl, p-cpe:/a:debian:debian_linux:php7.4-json, p-cpe:/a:debian:debian_linux:php7.4-ldap, p-cpe:/a:debian:debian_linux:php7.4-mbstring, p-cpe:/a:debian:debian_linux:php7.4-mysql, p-cpe:/a:debian:debian_linux:php7.4-odbc, p-cpe:/a:debian:debian_linux:php7.4-opcache, p-cpe:/a:debian:debian_linux:php7.4-pgsql, p-cpe:/a:debian:debian_linux:php7.4-phpdbg, p-cpe:/a:debian:debian_linux:php7.4-pspell, p-cpe:/a:debian:debian_linux:php7.4-readline, p-cpe:/a:debian:debian_linux:php7.4-snmp, p-cpe:/a:debian:debian_linux:php7.4-soap, p-cpe:/a:debian:debian_linux:php7.4-sqlite3, p-cpe:/a:debian:debian_linux:php7.4-sybase, p-cpe:/a:debian:debian_linux:php7.4-tidy, p-cpe:/a:debian:debian_linux:php7.4-xml, p-cpe:/a:debian:debian_linux:php7.4-xmlrpc, p-cpe:/a:debian:debian_linux:php7.4-xsl, p-cpe:/a:debian:debian_linux:php7.4-zip, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/25/2021

Vulnerability Publication Date: 10/25/2021

Reference Information

CVE: CVE-2021-21703

IAVA: 2021-A-0503