Mandrake Linux Security Advisory : xine-lib (MDKSA-2004:105)

High Nessus Plugin ID 15434


The remote Mandrake Linux host is missing one or more security updates.


A number of string overflows were discovered in the xine-lib program, some of which can be used for remote buffer overflow exploits that lead to the execution of arbitrary code with the permissions of the user running a xine-lib-based media application. xine-lib versions 1-rc2 through, and including, 1-rc5 are vulnerable to these problems.

As well, a heap overflow was found in the DVD subpicture decoder of xine-lib; this vulnerability is also remotely exploitable. All versions of xine-lib prior to and including 0.5.2 through, and including, 1-rc5 are vulnerable to this problem.

Patches from the xine-lib team have been backported and applied to the program to solve these problems.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 15434

File Name: mandrake_MDKSA-2004-105.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2004/10/08

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xine1, p-cpe:/a:mandriva:linux:lib64xine1-devel, p-cpe:/a:mandriva:linux:libxine1, p-cpe:/a:mandriva:linux:libxine1-devel, p-cpe:/a:mandriva:linux:xine-aa, p-cpe:/a:mandriva:linux:xine-arts, p-cpe:/a:mandriva:linux:xine-dxr3, p-cpe:/a:mandriva:linux:xine-esd, p-cpe:/a:mandriva:linux:xine-flac, p-cpe:/a:mandriva:linux:xine-gnomevfs, p-cpe:/a:mandriva:linux:xine-plugins, cpe:/o:mandrakesoft:mandrake_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/10/06

Reference Information

CVE: CVE-2004-1379, CVE-2004-1475, CVE-2004-1476

MDKSA: 2004:105