Palo Alto GlobalProtect Agent 5.0.x < 5.2.8 Buffer Overflow

high Nessus Plugin ID 154336
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A VPN client installed on remote host is affected by a buffer overflow vulnerability.


The version of Palo Alto GlobalProtect Agent installed on the remote host is 5.x prior to 5.2.8. It is, therefore, affected by a buffer overflow vulnerability when connecting to portal or gateway. A unathenticated remote attack could perform a man-in-the-middle attack to disrupt system processes and potentially execute arbitrary code with SYSTEM privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Palo Alto GlobalProtect Agent 5.2.8 or later

See Also

Plugin Details

Severity: High

ID: 154336

File Name: palo_alto_globalprotect_agent_cve-2021-3057.nasl

Version: 1.2

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 10/22/2021

Updated: 10/25/2021

Dependencies: palo_alto_globalprotect_agent_win_installed.nbin, palo_alto_globalprotect_agent_mac_installed.nbin

Risk Information

CVSS Score Source: CVE-2021-3057


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:paloaltonetworks:globalprotect

Required KB Items: installed_sw/Palo Alto GlobalProtect Agent

Exploit Ease: No known exploits are available

Patch Publication Date: 10/13/2021

Vulnerability Publication Date: 10/13/2021

Reference Information

CVE: CVE-2021-3057

IAVA: 2021-A-0476