Mozilla Multiple Products XPInstall Arbitrary File Overwrite

High Nessus Plugin ID 15432


The remote Windows host has a web browser installed that has file permissions set incorrectly.


The remote host is using Mozilla and/or Firefox, an alternative web browser.

The version of this software is prone to an improper file permission setting. This flaw only exists if the browser is installed by the Mozilla Foundation package management, therefore, this alert might be a false positive.

A local attacker could overwrite arbitrary files or execute arbitrary code in the context of the user running the browser.


Upgrade to Mozilla 1.7.3 or later.

See Also

Plugin Details

Severity: High

ID: 15432

File Name: mozilla_default_perms.nasl

Version: $Revision: 1.21 $

Type: local

Agent: windows

Family: Windows

Published: 2004/10/08

Modified: 2013/03/28

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:mozilla, cpe:/a:mozilla:firefox

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2004/09/13

Vulnerability Publication Date: 2004/09/14

Reference Information

CVE: CVE-2004-0906

BID: 11166

OSVDB: 10559