PHP 8.0.x < 8.0.12

high Nessus Plugin ID 154296
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version PHP running on the remote web server is affected by a vulnerability.

Description

The version of PHP installed on the remote host is prior to 8.0.12. It is, therefore, affected by a vulnerability as referenced in the Version 8.0.12 advisory.

- In PHP versions 7.3.x up to and including 7.3.31, 7.4.x below 7.4.25 and 8.0.x below 8.0.12, when running PHP FPM SAPI with main FPM daemon process running as root and child worker processes running as lower- privileged users, it is possible for the child processes to access memory shared with the main process and write to it, modifying it in a way that would cause the root process to conduct invalid memory reads and writes, which can be used to escalate privileges from local unprivileged user to the root user.
(CVE-2021-21703)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 8.0.12 or later.

See Also

http://bugs.php.net/81026

http://php.net/ChangeLog-8.php#8.0.12

Plugin Details

Severity: High

ID: 154296

File Name: php_8_0_12.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 10/21/2021

Updated: 11/5/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2021-21703

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 10/21/2021

Vulnerability Publication Date: 10/21/2021

Reference Information

CVE: CVE-2021-21703

IAVA: 2021-A-0503