Node.js Multiple Vulnerabilities (October 12th 2021 Security Releases)

medium Nessus Plugin ID 154235


Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.


The version of Node.js installed on the remote host is prior to 12.22.7, 14.18.1 or 16.11.1. It is, therefore, affected by multiple HTTP smuggling vulnerabilities. An unauthenticated, remote attack could exploit these to bypass security controls, gain unauthorized access to sensitive data and directly compromise other application users.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Node.js version 12.22.7, 14.18.1, 16.11.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 154235

File Name: nodejs_2021_oct_12.nasl

Version: 1.9

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 10/19/2021

Updated: 1/9/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Low

Score: 3.3


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2021-22959


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS Score Source: CVE-2021-22960

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: installed_sw/Node.js

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/12/2021

Vulnerability Publication Date: 10/12/2021

Reference Information

CVE: CVE-2021-22959, CVE-2021-22960

IAVB: 2021-B-0059-S