Node.js Multiple Vulnerabilities (August 31st 2021 Security Releases)

high Nessus Plugin ID 154232
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.


The version of Node.js installed on the remote host is prior to 12.22.6 or 14.17.6. It is, therefore, affected by multiple remote code execution vulnerabilities in various components due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this to bypass authentication and execute arbitrary commands. Additional impacts of these vulnerabilities include arbitrary file writing and creation.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Node.js version 12.22.6, 14.17.6 or later.

See Also

Plugin Details

Severity: High

ID: 154232

File Name: nodejs_2021_aug_31.nasl

Version: 1.2

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 10/19/2021

Updated: 10/21/2021

Dependencies: nodejs_win_installed.nbin, macosx_nodejs_installed.nbin

Risk Information

CVSS Score Source: CVE-2021-39135


Risk Factor: High

Score: 8.1


Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: installed_sw/Node.js

Exploit Ease: No known exploits are available

Patch Publication Date: 8/31/2021

Vulnerability Publication Date: 8/31/2021

Reference Information

CVE: CVE-2021-37701, CVE-2021-37712, CVE-2021-37713, CVE-2021-39134, CVE-2021-39135