Debian DSA-4989-1 : strongswan - security update

critical Nessus Plugin ID 154229

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 10 / 11 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-4989 advisory.

- The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur. (CVE-2021-41990)

- The in-memory certificate cache in strongSwan before 5.9.4 has a remote integer overflow upon receiving many requests with different certificates to fill the cache and later trigger the replacement of cache entries. The code attempts to select a less-often-used cache entry by means of a random number generator, but this is not done correctly. Remote code execution might be a slight possibility. (CVE-2021-41991)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the strongswan packages.

For the stable distribution (bullseye), these problems have been fixed in version 5.9.1-1+deb11u1.

See Also

https://security-tracker.debian.org/tracker/source-package/strongswan

https://www.debian.org/security/2021/dsa-4989

https://security-tracker.debian.org/tracker/CVE-2021-41990

https://security-tracker.debian.org/tracker/CVE-2021-41991

https://packages.debian.org/source/buster/strongswan

https://packages.debian.org/source/bullseye/strongswan

Plugin Details

Severity: Critical

ID: 154229

File Name: debian_DSA-4989.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/19/2021

Updated: 10/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-41991

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:charon-cmd, p-cpe:/a:debian:debian_linux:charon-systemd, p-cpe:/a:debian:debian_linux:libcharon-extauth-plugins, p-cpe:/a:debian:debian_linux:libcharon-extra-plugins, p-cpe:/a:debian:debian_linux:libstrongswan, p-cpe:/a:debian:debian_linux:libstrongswan-extra-plugins, p-cpe:/a:debian:debian_linux:libstrongswan-standard-plugins, p-cpe:/a:debian:debian_linux:strongswan, p-cpe:/a:debian:debian_linux:strongswan-charon, p-cpe:/a:debian:debian_linux:strongswan-libcharon, p-cpe:/a:debian:debian_linux:strongswan-nm, p-cpe:/a:debian:debian_linux:strongswan-pki, p-cpe:/a:debian:debian_linux:strongswan-scepclient, p-cpe:/a:debian:debian_linux:strongswan-starter, p-cpe:/a:debian:debian_linux:strongswan-swanctl, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/18/2021

Vulnerability Publication Date: 10/18/2021

Reference Information

CVE: CVE-2021-41990, CVE-2021-41991