Debian DLA-2786-1 : nghttp2 - LTS security update

high Nessus Plugin ID 154195

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-2786 advisory.

- nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service.
This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1. (CVE-2018-1000168)

- In nghttp2 before version 1.41.0, the overly large HTTP/2 SETTINGS frame payload causes denial of service.
The proof of concept attack involves a malicious client constructing a SETTINGS frame with a length of 14,400 bytes (2400 individual settings entries) over and over again. The attack causes the CPU to spike at 100%. nghttp2 v1.41.0 fixes this vulnerability. There is a workaround to this vulnerability. Implement nghttp2_on_frame_recv_callback callback, and if received frame is SETTINGS frame and the number of settings entries are large (e.g., > 32), then drop the connection. (CVE-2020-11080)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the nghttp2 packages.

For Debian 9 stretch, these problems have been fixed in version 1.18.1-1+deb9u2.

See Also

https://security-tracker.debian.org/tracker/source-package/nghttp2

https://www.debian.org/lts/security/2021/dla-2786

https://security-tracker.debian.org/tracker/CVE-2018-1000168

https://security-tracker.debian.org/tracker/CVE-2020-11080

https://packages.debian.org/source/stretch/nghttp2

Plugin Details

Severity: High

ID: 154195

File Name: debian_DLA-2786.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/17/2021

Updated: 10/17/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2020-11080

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:nghttp2:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libnghttp2-14:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libnghttp2-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libnghttp2-doc:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:nghttp2-client:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:nghttp2-proxy:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:nghttp2-server:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/16/2021

Vulnerability Publication Date: 4/12/2018

Reference Information

CVE: CVE-2018-1000168, CVE-2020-11080