Ubuntu 20.04 LTS : Linux kernel (OEM) vulnerabilities (USN-5106-1)

high Nessus Plugin ID 153908

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 20.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5106-1 advisory.

- The Linux kernel through 5.8.13 does not properly enforce the Secure Boot Forbidden Signature Database (aka dbx) protection mechanism. This affects certs/blacklist.c and certs/system_keyring.c.
(CVE-2020-26541)

- An out-of-bounds memory write flaw was found in the Linux kernel's joystick devices subsystem in versions before 5.9-rc1, in the way the user calls ioctl JSIOCSBTNMAP. This flaw allows a local user to crash the system or possibly escalate their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. (CVE-2021-3612)

- An issue was discovered in Linux: KVM through Improper handling of VM_IO|VM_PFNMAP vmas in KVM can bypass RO checks and can lead to pages being freed while still accessible by the VMM and guest. This allows users with the ability to start and control a VM to read/write random pages of memory and can result in local privilege escalation. (CVE-2021-22543)

- ** DISPUTED ** In drivers/char/virtio_console.c in the Linux kernel before 5.13.4, data corruption or loss can be triggered by an untrusted device that supplies a buf->len value exceeding the buffer size. NOTE:
the vendor indicates that the cited data corruption is not a vulnerability in any existing use case; the length validation was added solely for robustness in the face of anomalous host OS behavior.
(CVE-2021-38160)

- fs/nfs/nfs4client.c in the Linux kernel before 5.13.4 has incorrect connection-setup ordering, which allows operators of remote NFSv4 servers to cause a denial of service (hanging of mounts) by arranging for those servers to be unreachable during trunking detection. (CVE-2021-38199)

- loop_rw_iter in fs/io_uring.c in the Linux kernel 5.10 through 5.14.6 allows local users to gain privileges by using IORING_OP_PROVIDE_BUFFERS to trigger a free of a kernel buffer, as demonstrated by using /proc//maps for exploitation. (CVE-2021-41073)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5106-1

Plugin Details

Severity: High

ID: 153908

File Name: ubuntu_USN-5106-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/7/2021

Updated: 10/7/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-41073

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:linux-buildinfo-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-headers-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-headers-oem-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-headers-oem-20.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-headers-oem-20.04b, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem-20.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem-20.04b, p-cpe:/a:canonical:ubuntu_linux:linux-image-unsigned-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-modules-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-oem-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-oem-20.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-oem-20.04b, p-cpe:/a:canonical:ubuntu_linux:linux-oem-5.10-headers-5.10.0-1049, p-cpe:/a:canonical:ubuntu_linux:linux-oem-5.10-tools-5.10.0-1049, p-cpe:/a:canonical:ubuntu_linux:linux-oem-5.10-tools-host, p-cpe:/a:canonical:ubuntu_linux:linux-tools-5.10.0-1049-oem, p-cpe:/a:canonical:ubuntu_linux:linux-tools-oem-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-tools-oem-20.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-tools-oem-20.04b

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/6/2021

Vulnerability Publication Date: 10/2/2020

Reference Information

CVE: CVE-2020-26541, CVE-2021-3612, CVE-2021-22543, CVE-2021-38160, CVE-2021-38199, CVE-2021-41073

USN: 5106-1