Amazon Linux 2 : sssd (ALAS-2021-1715)

high Nessus Plugin ID 153899

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of sssd installed on the remote host is prior to 1.16.5-10. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2021-1715 advisory.

- A flaw was found in SSSD, where the sssctl command was vulnerable to shell command injection via the logs- fetch and cache-expire subcommands. This flaw allows an attacker to trick the root user into running a specially crafted sssctl command, such as via sudo, to gain root access. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. (CVE-2021-3621)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update sssd' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2021-1715.html

https://access.redhat.com/security/cve/CVE-2021-3621

Plugin Details

Severity: High

ID: 153899

File Name: al2_ALAS-2021-1715.nasl

Version: 1.4

Type: local

Agent: unix

Published: 10/6/2021

Updated: 1/10/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-3621

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:libipa_hbac, p-cpe:/a:amazon:linux:libipa_hbac-devel, p-cpe:/a:amazon:linux:libsss_autofs, p-cpe:/a:amazon:linux:libsss_certmap, p-cpe:/a:amazon:linux:libsss_certmap-devel, p-cpe:/a:amazon:linux:libsss_idmap, p-cpe:/a:amazon:linux:libsss_idmap-devel, p-cpe:/a:amazon:linux:libsss_nss_idmap, p-cpe:/a:amazon:linux:libsss_nss_idmap-devel, p-cpe:/a:amazon:linux:libsss_simpleifp, p-cpe:/a:amazon:linux:libsss_simpleifp-devel, p-cpe:/a:amazon:linux:libsss_sudo, p-cpe:/a:amazon:linux:python-libipa_hbac, p-cpe:/a:amazon:linux:python-libsss_nss_idmap, p-cpe:/a:amazon:linux:python-sss, p-cpe:/a:amazon:linux:python-sss-murmur, p-cpe:/a:amazon:linux:python-sssdconfig, p-cpe:/a:amazon:linux:sssd, p-cpe:/a:amazon:linux:sssd-ad, p-cpe:/a:amazon:linux:sssd-client, p-cpe:/a:amazon:linux:sssd-common, p-cpe:/a:amazon:linux:sssd-common-pac, p-cpe:/a:amazon:linux:sssd-dbus, p-cpe:/a:amazon:linux:sssd-debuginfo, p-cpe:/a:amazon:linux:sssd-ipa, p-cpe:/a:amazon:linux:sssd-kcm, p-cpe:/a:amazon:linux:sssd-krb5, p-cpe:/a:amazon:linux:sssd-krb5-common, p-cpe:/a:amazon:linux:sssd-ldap, p-cpe:/a:amazon:linux:sssd-libwbclient, p-cpe:/a:amazon:linux:sssd-libwbclient-devel, p-cpe:/a:amazon:linux:sssd-polkit-rules, p-cpe:/a:amazon:linux:sssd-proxy, p-cpe:/a:amazon:linux:sssd-tools, p-cpe:/a:amazon:linux:sssd-winbind-idmap, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 10/4/2021

Vulnerability Publication Date: 8/16/2021

Reference Information

CVE: CVE-2021-3621

ALAS: 2021-1715