Amazon Linux 2 : libsndfile (ALAS-2021-1713)

high Nessus Plugin ID 153897

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of libsndfile installed on the remote host is prior to 1.0.25-12. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2021-1713 advisory.

- A heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file. (CVE-2021-3246)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update libsndfile' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2021-1713.html

https://access.redhat.com/security/cve/CVE-2021-3246

Plugin Details

Severity: High

ID: 153897

File Name: al2_ALAS-2021-1713.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/6/2021

Updated: 10/6/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-3246

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:libsndfile, p-cpe:/a:amazon:linux:libsndfile-debuginfo, p-cpe:/a:amazon:linux:libsndfile-devel, p-cpe:/a:amazon:linux:libsndfile-utils, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 10/4/2021

Vulnerability Publication Date: 7/20/2021

Reference Information

CVE: CVE-2021-3246

ALAS: 2021-1713