Apache 2.4.49 < 2.4.50 Multiple Vulnerabilities

high Nessus Plugin ID 153884

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

The version of Apache httpd installed on the remote host is 2.4.49. It is, therefore, affected by multiple vulnerabilities as referenced in the 2.4.50 advisory.

- While fuzzing the 2.4.49 httpd, a new null pointer dereference was detected during HTTP/2 request processing, allowing an external source to DoS the server. This requires a specially crafted request. The vulnerability was recently introduced in version 2.4.49. No exploit is known to the project.
(CVE-2021-41524)

- A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the expected document root. If files outside of the document root are not protected by require all denied these requests can succeed. Additionally this flaw could leak the source of interpreted files like CGI scripts. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. (CVE-2021-41773)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.50 or later.

See Also

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin Details

Severity: High

ID: 153884

File Name: apache_2_4_50.nasl

Version: 1.12

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 10/5/2021

Updated: 4/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-41773

VPR

Risk Factor: High

Score: 7.2

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/4/2021

Vulnerability Publication Date: 10/4/2021

CISA Known Exploited Dates: 11/17/2021

Exploitable With

Metasploit (Apache 2.4.49/2.4.50 Traversal RCE)

Reference Information

CVE: CVE-2021-41524, CVE-2021-41773

IAVA: 2021-A-0451-S