ManageEngine EventLog Analyzer < Build 12201 REST API Restriction Bypass RCE

critical Nessus Plugin ID 153848

Synopsis

A log management application running on the remote host is affected by a remote code execution vulnerability.

Description

The ManageEngine EventLog Analyzer running on the remote host is affected by a security restriction bypass vulnerability due to improper validation of user-supplied data. An unauthenticated, remote attacker can exploit this, via a specially crafted message, to execute arbitrary code on the remote host.

Solution

Upgrade to EventLog Analyzer build 12201 or later.

See Also

https://www.manageengine.com/products/eventlog/release-notes.html

Plugin Details

Severity: Critical

ID: 153848

File Name: manageengine_eventlog_analyzer_cve-2021-40539.nbin

Version: 1.27

Type: remote

Family: CGI abuses

Published: 10/4/2021

Updated: 10/5/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2021-40539

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:zohocorp:manageengine_eventlog_analyzer

Required KB Items: installed_sw/ManageEngine EventLog Analyzer

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/9/2021

Vulnerability Publication Date: 9/9/2021

CISA Known Exploited Dates: 11/17/2021

Exploitable With

Metasploit (ManageEngine ADSelfService Plus CVE-2021-40539)

Reference Information

CVE: CVE-2021-40539